Project

General

Profile

Bug #3709

Links filtering is sometimes wrong

Added by Yannick Warnier over 8 years ago. Updated about 8 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
-
Target version:
Start date:
16/07/2011
Due date:
% Done:

0%

Estimated time:
0.25 h
Spent time:
Complexity:
Piece of cake
SCRUM pts - complexity:
1

Description

Although not easily reproducible, sometimes the link filtering returns an error for a completely valid link. This is caused by the PHP filtering:


                if (!filter_var($urllink, FILTER_VALIDATE_URL)) {
                        $msgErr = get_lang('GiveURL');
                        Display::display_error_message(get_lang('GiveURL'));
                        $ok = false;
                }

on line 56 of main/link/linkfunctions.php

Although it doesn't generate the error systematically, the language variable used as an error message (GiveURL) is not adapted. Rather, it should be something like $URLCouldNotBeValidated = "This link could not be validated because it is empty or it contains accentuated characters. Please try again with a cleaner link.";

History

#1

Updated by Bryan Fuertes Malca about 8 years ago

  • Assignee set to Bryan Fuertes Malca
#2

Updated by Bryan Fuertes Malca about 8 years ago

  • Status changed from New to Rejected - Abandoned

This bug was already fixed in 1.8.8 thanks to Ivan Tcholakov to avoid a bug in filter_var() (the linkfunctions.php file was moved to main/inc/lib/link.lib.php)

Also available in: Atom PDF