Project

General

Profile

Bug #3614

chinese name in wrong order 1.8.8.2

Added by mic yu almost 9 years ago. Updated over 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
17/06/2011
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

1.I install new chamilo 1.8.8.2,
during installation, I choose smiplified chinese.
after that, I noticed first name and last name is in wrong order for chinese,which is first name followed by last name.(in chinese, it should be last name then first name)

2.then I go to file the file .../chamilo/main/inc/lib/internationalization_database/name_order_conventions.php
it shows below (which is correct writing)

-------
'simpl_chinese' => array( 'format' => 'title last_name first_name', 'sort_by' => 'last_name' ), // Eastern order
-------

3.temp walkaround I am using, change code below, change last_name first_name to first_name last_name e.g.

-----------
'simpl_chinese' => array( 'format' => 'title first_name last_name', 'sort_by' => 'last_name' ), // Eastern order
-----------

though it is not proper way, but it solve problem temp. chinese name can be shown in proper order, which is last name followed by first name.

Associated revisions

Revision becf937e (diff)
Added by Yannick Warnier over 7 years ago

Added section about language name order in installation guide - refs #3614

History

#1

Updated by Julio Montoya almost 9 years ago

  • Status changed from New to Needs more info

I don't know what to say here .. anybody else who speaks Chinese?

According to wikipedia:

(...) a Chinese name is written with the family name first and the given name next

http://en.wikipedia.org/wiki/Chinese_name

#2

Updated by mic yu almost 9 years ago

may be need to change chinese translation file about first name and last name definition,
any one know where to change?

#3

Updated by Yannick Warnier almost 8 years ago

  • Target version set to 1.9 Beta
#4

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 1.9 Beta to 2.0
#5

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 2.0 to 1.9 RC1
#6

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Bug resolved
  • % Done changed from 0 to 100

I think the right thing to do is to change the installation documentation so people know where to change this. Apart from that, I don't see much we can do, no.

I just sent the corresponding update to the installation guide.

Also available in: Atom PDF