Project

General

Profile

Bug #3613

change lang problem

Added by mic yu almost 9 years ago. Updated over 7 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
-
Target version:
Start date:
17/06/2011
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

I installed new chamilo 1.8.8.2, during installation, I choose smiplified chinese,
after installation, during login,if I change lang from chinese to english,but only the login page is in english,after login, it still show chinese words in menu. and no where to choose which lang to use after login.

History

#1

Updated by Julio Montoya almost 9 years ago

The language priority works like this for example:

1. Platform language : English
2. Course language : Spanish
3. User language : Chinese

In the case that we are inside a course "Spanish" will override "English". The user language will not interfere.

If I'm in the user_portal.php or index.php page the language that the system will take will be Chinese because my user language is priority than the platform language.

If you want that after the login the platform language is the same as the user language you have to change your personal settings in:

example.com/main/auth/profile.php

You can edit some settings so you can manage if student can edit their language, just edit the settings in:
main/admin/settings.php?category=User

#2

Updated by Yannick Warnier almost 8 years ago

  • Target version set to 1.9 Beta
#3

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 1.9 Beta to 2.0
#4

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 2.0 to 1.9 RC1
#5

Updated by Laurent Opprecht almost 8 years ago

  • Status changed from New to Needs more info
  • Assignee set to Yannick Warnier

I would tag that issue as "rejected" as it is not a bug per se. It comes from a missunderstanding of the way language management works.
I must admit I had the same issue but I don't see much we can do about it. Maybe some help files.

#6

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Rejected - Abandoned

Thanks Mic for your report. However, until this issue is reported in a way that allows us to improve the current situation (giving suggestions of what we could do), we won't be able to really improve it. Please don't hesitate to add information and we will re-open it.

Also available in: Atom PDF