Project

General

Profile

Bug #3585

Whoisonline user thumbnail not updated

Added by Yannick Warnier about 8 years ago. Updated almost 8 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
-
Target version:
Start date:
10/06/2011
Due date:
% Done:

0%

Estimated time:
1.50 h
Complexity:
Normal
SCRUM pts - complexity:
8

Description

When a user uploads a large picture, the picture doesn't seem to be resized well, or maybe the whoisonline page doesn't recover the right thumbnail size... Ether way, there are several users on campus.chamilo.org with just their hair appearing, and when you upload a new picture (smaller), the thumbnail from whoisonline is not refreshed... Not looking good!


Files

Pantallazo-2.png (86.3 KB) Pantallazo-2.png Yannick Warnier, 04/08/2011 08:21

History

#1

Updated by Julio Montoya about 8 years ago

  • Status changed from New to Needs more info

I sent some changes for 1.8.8.3 in order to fix that using CSS3 properties (clip, transform) but is not a perfect solution.

We could implement that something like that:

http://code.google.com/p/jcrop/

http://deepliquid.com/projects/Jcrop/demos.php

#2

Updated by Julio Montoya about 8 years ago

In fact, the images are well resize the problem is the CSS style that tries to hide part of the image in order to have a perfect square ....

#3

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Julio Montoya

No, the images have to be really resized. They should be saved in several formats (3, I think) when uploaded, and CSS should not have anything to do with that.
There is code somewhere to do that (the resizing when uploading the picture), but apparentky it doesn't work.

#4

Updated by Julio Montoya almost 8 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier

Yannick Warnier wrote:

No, the images have to be really resized. They should be saved in several formats (3, I think) when uploaded, and CSS should not have anything to do with that.
There is code somewhere to do that (the resizing when uploading the picture), but apparentky it doesn't work.

The images are really resized. CSS only hides part of the resize image in order to have something like a square. Otherwise some images will be bigger than others (portrait).

The resize works for me. I test it also in chamilodev today

http://chamilodev.beeznest.com/main/upload/users/14/14_4e36c3a70cd78_koala.jpg?4e36c3a83d313
http://chamilodev.beeznest.com/main/upload/users/14/medium_14_4e36c3a70cd78_koala.jpg?4e36c3a83d313
http://chamilodev.beeznest.com/main/upload/users/14/big_14_4e36c3a70cd78_koala.jpg?4e36c3a83d313
http://chamilodev.beeznest.com/main/upload/users/14/small_14_4e36c3a70cd78_koala.jpg?4e36c3a83d313

#5

Updated by Yannick Warnier almost 8 years ago

OK. It must have been something wrong in the past then.

How do you explain the following screenshot, showing what appears on chamilodev when I look for "john" in the search box of my social network? See how my picture is resized strangely in comparison with the bigger image on the left? Anything anormal there or we just say that this is normality?

#6

Updated by Julio Montoya almost 8 years ago

  • Assignee changed from Julio Montoya to Yannick Warnier
#7

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Bug resolved

Fixed. Great!

Also available in: Atom PDF