Project

General

Profile

Support #3262

is there a instruction to download/sync latest code repository

Added by mic yu over 8 years ago. Updated over 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
14/04/2011
Due date:
% Done:

0%

Estimated time:
Complexity:
Easy
SCRUM pts - complexity:
?

Description

is there a instruction to download/sync latest code repository
btw,I am a php developer.I wish I can contribute to chamilo in future also.

History

#1

Updated by mic yu over 8 years ago

I went to chamilo google code try to get a clone to my local use below command
hg clone https://chamilo.chamilo.googlecode.com/hg/ chamilo-chamilo
but it seems not the current repository, because the files there are not the same as in download version.
I use TortoiseHG to clone

#2

Updated by mic yu over 8 years ago

I intend to clone 1.8.8 latest version.
I explored under http://code.google.com/p/chamilo
still cann't find why is the correct repository

#3

Updated by mic yu over 8 years ago

then I intended to clone below
https://classic.chamilo.googlecode.com/hg/ chamilo-classic
it shows error below ===========
% hg clone --verbose https://classic.chamilo.googlecode.com/hg/ chamilo-classic -- .
abort: classic.chamilo.googlecode.com certificate error: certificate is for *.googlecode.com, googlecode.com, *.codespot.com (use --insecure to connect insecurely)
[command returned code 255 Thu Apr 14 10:21:36 2011] ===========

#4

Updated by mic yu over 8 years ago

pls help to close this issue

#5

Updated by Julio Montoya over 8 years ago

  • Status changed from New to Needs more info

hello

you can go to this page to download the current Chamilo 1.8.x hg repository

http://code.google.com/p/chamilo/source/checkout?repo=classic

You can run this in your terminal

hg clone https://classic.chamilo.googlecode.com/hg/ XXX

Where XXX is the folder that you want for your installation

If you are using tortoise use this URL

https://classic.chamilo.googlecode.com/hg/

You must accept the google certificate that may be prompt by tortoise ...

#6

Updated by Marko Kastelic over 8 years ago

*.googlecode.com, googlecode.com, *.codespot.com (use --insecure to connect insecurely)

do not use certificate; just use fingerprint or no verification
https://bitbucket.org/tortoisehg/thg/issue/79/certificate-error-probably-wrong-code-for

#7

Updated by Yannick Warnier over 7 years ago

  • Target version set to 1.9 Beta
#8

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Bug resolved

I'm closing this task. Feel free to continue discussing it if necessary (but I think the initial question has been covered)

Also available in: Atom PDF