Project

General

Profile

Bug #3215

Registration not possible

Added by Anonymous over 10 years ago. Updated over 10 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
06/04/2011
Due date:
08/04/2011
% Done:

100%

Estimated time:
Complexity:
Normal

Description

I've switched the settings to allow users to manually register, but every time I click on the button to register (homepage), I get a "The user is already registered" message.
I've tried to click on the button while my (already registered) username is filled in, I've also tried it when a new non-existing username is filled in and I've tested it with a blank username field, none of them seem to work.

Sounds like a bug to me :)

History

#1

Updated by Anonymous over 10 years ago

  • Due date set to 08/04/2011
  • Status changed from New to Assigned
  • Assignee set to Anonymous
#2

Updated by Anonymous over 10 years ago

  • Status changed from Assigned to Needs testing
  • % Done changed from 0 to 100

The check if a user exists is fooled by the anonymous user... remove the check and the registration problem is solved.

There is no need for a check anyway since everybody can just register by loging out... so why check for something that can easily be ommited???

#3

Updated by Stefaan Vanbillemont over 10 years ago

  • Target version changed from 21 to 2.1.0
#4

Updated by Stefaan Vanbillemont over 10 years ago

  • Status changed from Needs testing to Bug resolved

Tested and fixend

Also available in: Atom PDF