Project

General

Profile

Bug #2978

GenericTree not found

Added by Laurent Opprecht over 8 years ago. Updated over 8 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
01/03/2011
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

In course tools clock on Announcement

Fatal error: Class 'common\libraries\GenericTree' not found in C:\wamp\www\chamilo\application\weblcms\php\lib\browser\publication_categories_tree.class.php on line 29
Call Stack
  1. Time Memory Function Location
    1 0.0007 339808 {main}( ) ..\run.php:0
    2 0.1424 7649664 common\libraries\Application::launch( ) ..\run.php:40
    3 0.2417 15592624 application\weblcms\WeblcmsManagerCourseViewerComponent->run( ) ..\application.class.php:852
    4 0.2483 15646048 application\weblcms\Tool::launch( ) ..\course_viewer.class.php:170
    5 0.2493 15674960 common\libraries\SubManager::launch( ) ..\tool.class.php:605
    6 0.2518 15746136 application\weblcms\tool\announcement\AnnouncementToolBrowserComponent->run( ) ..\sub_manager.class.php:355
    7 0.2518 15746136 application\weblcms\ToolComponent::launch( ) ..\browser.class.php:26
    8 0.2518 15746248 common\libraries\SubManager::launch( ) ..\tool_component.class.php:193
    9 0.2518 15746248 common\libraries\SubManager::construct( ) ..\sub_manager.class.php:355
    10 0.2518 15746336 common\libraries\SubManager::component( ) ..\sub_manager.class.php:315
    11 0.2518 15746336 common\libraries\SubManager::load_class( ) ..\sub_manager.class.php:282
    12 0.2537 15923864 require_once( 'C:\wamp\www\chamilo\application\weblcms\php\lib\tool\component\browser.class.php' ) ..\sub_manager.class.php:269
    13 0.2567 16179792 require_once( 'C:\wamp\www\chamilo\application\weblcms\php\lib\browser\publication_categories_tree.class.php' ) ..\browser.class.php:34

History

#1

Updated by Sven Vanpoucke over 8 years ago

  • Status changed from New to Needs testing

Is you core also updated? Because this is an autoloader that is in the core. This is working for me though.

#2

Updated by Laurent Opprecht over 8 years ago

I am working with dev:

https://laurentopprecht@bitbucket.org/chamilo/chamilo-dev
https://bitbucket.org/chamilo/chamilo-app-weblcms-dev

and yes both are merged with the latest releases.

Still not working.

#3

Updated by Sven Vanpoucke over 8 years ago

Bug is not yet fixed on dev, only on stable.

#4

Updated by Laurent Opprecht over 8 years ago

  • Status changed from Needs testing to Bug resolved

k thanks

#5

Updated by Stefaan Vanbillemont over 8 years ago

  • Project changed from Chamilo LCMS Connect to Courses
  • Category deleted (2)
#6

Updated by Stefaan Vanbillemont over 8 years ago

  • Target version set to 2.1.0

Also available in: Atom PDF