Project

General

Profile

Bug #2911

zip/tar files break when uploading/downloading to chamilo

Added by Yannick Warnier almost 11 years ago. Updated 3 months ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
-
Target version:
-
Start date:
19/02/2011
Due date:
% Done:

0%

Estimated time:
2.00 h
Complexity:
Challenging
SCRUM pts - complexity:
8

Description

For some reason, all archives compressed and uploaded from Ubuntu to Chamilo 1.8.8dev are broken when trying to download and open them in Ubuntu...

  • create a folder with 2 images on your desktop
  • zip the folder (right click)
  • upload the zip to a Chamilo document tool (any course, but tried in a French course on http://chamilodev.beeznest.com as admin)
  • download the zip -> broken archive
  • try uploading the zip with "uncompress zip file"
  • download the folder as zip -> broken archive

Files

bad_zip_header_found.png (98.6 KB) bad_zip_header_found.png Ivan Tcholakov, 19/02/2011 20:19
bad_zip_header_found_2.png (61.4 KB) bad_zip_header_found_2.png Ivan Tcholakov, 19/02/2011 20:19
config_1.png (22.6 KB) config_1.png Ivan Tcholakov, 20/02/2011 02:01
config_2.png (32.1 KB) config_2.png Ivan Tcholakov, 20/02/2011 02:01
zip-compression-comparison-bad-good.png (97 KB) zip-compression-comparison-bad-good.png Ivan Tcholakov, 20/02/2011 05:11

History

#1

Updated by Ivan Tcholakov almost 11 years ago

My testing environment: Windows Vista, XAMPP 1.7.4. I am using IZArc and 7z as desktiop (de)archivers.

1. I did the described testing procedure nn my local testing system Chamilo, everything is ok.

2. I repeated the procedure on a course in http://chamilodev.beeznest.com . When I downloaded the testing folder as zip and tried to open it with IZArc an error message appears - "Bad zip header found.". Still it was possible the files to be extracted, but the file is corrupted, indeed. 7z can't work with thus corrupted file at all.

At the moment I can confirm the bug for the site http://chamilodev.beeznest.com . I will try to reproduce it using a local testing system under Ubuntu.

#2

Updated by Ivan Tcholakov almost 11 years ago

I did the same test on Ubuntu 10.10, 64-bit. I can uncompress without problems the downloaded zip-archive using the application "file-roller" (the default archiver for Ubuntu). I can't reproduce the bug with my configuration.

#3

Updated by Ivan Tcholakov almost 11 years ago

It seems to me that the chamilodev site cuts several bytes at the end of the zip file while it is downloaded. See the attached image.

#4

Updated by Yannick Warnier over 10 years ago

OK, maybe the use of zlib.output_compression is having something to do with this? Both http://chamilodev.beeznest.com and campus.chamilo.org have that setting set to ON... I must do more testing around this.

#5

Updated by Yannick Warnier over 10 years ago

  • Assignee set to Yannick Warnier
  • Target version changed from 1.8.8 beta to 1.8.8 stable
#6

Updated by Yannick Warnier over 10 years ago

  • Target version changed from 1.8.8 stable to 1.8.8.4

Not occuring when no compression is enabled. I've also seen a few params out there for the web server to not enable content compression when the file is already a zip or a gz, so I guess this proves the point.
I still want to check it before 1.8.8.1 though...

#7

Updated by Yannick Warnier over 10 years ago

  • Target version changed from 1.8.8.4 to 1.9 Stable
#8

Updated by Yannick Warnier over 9 years ago

  • Target version changed from 1.9 Stable to 1.9 Beta
#9

Updated by Yannick Warnier over 9 years ago

  • Target version changed from 1.9 Beta to 1.9 RC1
#10

Updated by Yannick Warnier over 9 years ago

  • Status changed from New to Assigned
  • Target version deleted (1.9 RC1)

Moving to no specific version. Not urgent.

#11

Updated by Yannick Warnier almost 9 years ago

  • Target version set to 1.9.6
#12

Updated by Yannick Warnier over 8 years ago

  • Target version deleted (1.9.6)
#13

Updated by Yannick Warnier 3 months ago

  • Status changed from Assigned to Rejected - Abandoned

Also available in: Atom PDF