Project

General

Profile

Bug #2711

Can't display test result if user has a name with a ' in it

Added by Peter Van den Broeck over 8 years ago. Updated over 8 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
31/01/2011
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

If I want to display test results or even correct test, I have found that I can't do this if the user has a name with a ' in it. Somehow the code misinterprets the ' as the end of the line (because ' has a different function in SQL and php).

Can't this problem be resolved by somehow resripting the exercise so as the results be extracted by using the user's unique ID (User number) instead of the name. Dutch and Flemish (and I beleiev even French) names with a ' in it are quite common.

example of the generated link. I've bolded the name to indicate the problem area. This is a mock link. The actual one I get is printed below.

What it should be:
http://campus/main/exercice/exercise_show.php?cidReq=2010VBP008&action=qualify&user=*Louise%20D'hondt*&dt=donderdag%2027%20januari%202011%20om%2013:27&res=11.00&id=976&email=x@x.com

What you get:
http://campus/main/exercice/exercise_show.php?cidReq=2010VBP008&action=qualify&user=*Louise%20D*

History

#1

Updated by Julio Montoya over 8 years ago

  • Status changed from New to Needs more info
  • % Done changed from 0 to 50

Hello Peter,
Thanks for reporting! We improved a little bit the exercise tool so as far as I know this was already fixed, you can test it in our server installed with a nighly build of Chamilo

http://chamilodev.beeznest.com/index.php

#2

Updated by Julio Montoya over 8 years ago

  • Status changed from Needs more info to Bug resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF