Project

General

Profile

Bug #2585

Fatal error on playing SCORM content

Added by Ivan Tcholakov almost 9 years ago. Updated over 8 years ago.

Status:
Bug resolved
Priority:
Normal
Target version:
Start date:
20/01/2011
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

I am testing the current code under development (post Chamilo 2.0) rev b0d67e3371 .

I imported in the Learning Paths tool these SCORM packages (see the picture):
pfpdev.ethz.ch/SCORMcontent/12181.zip
pfpdev.ethz.ch/SCORMcontent/42285.zip

When I tried to preview them by clicking on the titles I got the following:

Fatal error: Class application\weblcms\tool\learning_path\LearningPathToolComplexDisplayComponent contains 2 abstract methods and must therefore be declared abstract or implement the remaining methods (repository\content_object\assessment\AssessmentComplexDisplaySupport::get_assessment_question_attempts, repository\content_object\assessment\AssessmentComplexDisplaySupport::get_assessment_question_attempt) in C:\xampp\htdocs\chamilo2\application\weblcms\tool\learning_path\php\component\complex_display.class.php on line 383

Files

SCORM_packages_imported.png (68.9 KB) SCORM_packages_imported.png Ivan Tcholakov, 20/01/2011 23:31
the_fatal_error.png (101 KB) the_fatal_error.png Ivan Tcholakov, 20/01/2011 23:37
SCORM_preview_sample.png (134 KB) SCORM_preview_sample.png Ivan Tcholakov, 21/01/2011 13:47
42285_on_chamilo_188alpha.png (92.1 KB) 42285_on_chamilo_188alpha.png Ivan Tcholakov, 25/01/2011 10:56
42285_on_chamilo_2plus.png (99 KB) 42285_on_chamilo_2plus.png Ivan Tcholakov, 25/01/2011 10:56

History

#2

Updated by Sven Vanpoucke almost 9 years ago

  • Status changed from New to Needs testing
  • Assignee set to Sven Vanpoucke
  • Target version set to 21
#3

Updated by Ivan Tcholakov almost 9 years ago

Yes, it works for me. Thank you.

#4

Updated by Ludwig Theunis almost 9 years ago

  • Status changed from Needs testing to Bug resolved

The error does not appear anymore. So the bug is fixed.

But cannot import the 42285.zip scorm. Bug ?

Gives chamilo message: Object not imported.

#5

Updated by Ivan Tcholakov almost 9 years ago

This is strange. I tried 42285.zip on both Chamilo 1.8.8alpha and the current Chamilo 2.0+. It works for me.
I did the tests on Windows Vista, XAMPP 1.7.3.

#6

Updated by Stefaan Vanbillemont over 8 years ago

  • Project changed from Chamilo LCMS Connect to Courses
  • Category deleted (39)
#7

Updated by Stefaan Vanbillemont over 8 years ago

  • Target version changed from 21 to 2.1.0

Also available in: Atom PDF