Project

General

Profile

Bug #2470

profile pictures for users with special chars in their names

Added by Nathalie Blocry almost 11 years ago. Updated about 10 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Hans De Bisschop
Target version:
Start date:
14/12/2010
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

if a user has a é in his/her name the uploading of a profile picture will fail without warning.

we should remove the user's name from the picture's name because it isn't used anyway.

Associated revisions

Revision 8a465b29 (diff)
Added by jmontoyaa over 3 years ago

Fix course backup creation. Fix scorm folder see #2470

History

#1

Updated by Nathalie Blocry almost 11 years ago

  • Status changed from New to Needs testing

removed the user's name from the filename

#2

Updated by Michael Hosdez almost 11 years ago

  • Status changed from Needs testing to Assigned

When é, à, è or other accents are used in the filename of a picture the user picture is not uploaded and added into the account information.

#3

Updated by Nathalie Blocry almost 11 years ago

  • Assignee changed from Nathalie Blocry to Hans De Bisschop

function create_safe_name($desired_name) in filesystem.class.php creates a faulty name but I am not allowed to fix it since it's in the core

#4

Updated by Stefaan Vanbillemont almost 11 years ago

  • Target version set to 21
#5

Updated by Hans De Bisschop over 10 years ago

  • Project changed from Chamilo LCMS Connect to User
  • Category deleted (7)
#6

Updated by Stefaan Vanbillemont over 10 years ago

  • Target version changed from 21 to 2.1.0
#7

Updated by Stefaan Vanbillemont about 10 years ago

  • Status changed from Assigned to Bug resolved

Retested and no issue anymore

Also available in: Atom PDF