Project

General

Profile

Bug #2463

adding/publishing existing items through the repoviewer

Added by Nathalie Blocry almost 11 years ago. Updated over 10 years ago.

Status:
Feature implemented
Priority:
Normal
Assignee:
-
Target version:
Start date:
07/12/2010
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

Fatal error: Class 'common\\extensions\\repo_viewer\Autoloader' not found in /var/www/CHAMILO_EDISON/common/libraries/php/utilities.class.php on line 594

I get the same error in every context where I use the browse tab of the repoviewer.
e.g:
in the repository when I want to add an item to a portfolio in the complex builder
in the handbook application when i try to publish a handbook I already made
in the weblcms when trying to publish a document from the repository
...

in stable and in latest code

Associated revisions

Revision 034656cc (diff)
Added by jmontoyaa over 3 years ago

Notebook teacher - Minor improvements

- Format code
- readme is now a markdown
- Use ChamiloSession instead of $_SESSION
- Rename classes
- Use api_get_plugin_setting
- deleted unused file

See #2463

History

#1

Updated by Nathalie Blocry almost 11 years ago

trying to debug this but I can't find out where this problem originates.

when I check the sourcecode of the form that was generated I see the correct namespace
<input type="hidden" name="content_object_table_namespace" value="common\extensions\repo_viewer"/>

but after posting the form the value of the POST-variable [content_object_table_namespace] is common\\extensions\\repo_viewer -> this causes all the problems but I don't know where it comes from.

#2

Updated by Hans De Bisschop almost 11 years ago

I can't even reproduce the problem :(

#3

Updated by Nathalie Blocry almost 11 years ago

scary! I cannot publish anything from the repository with the repo-viewer in Edison or latest code.
Makes it a server-setting-problem then?! apache adding the extra "\" ?
I will ask Jens tomorrow if he has the same problem with more or less the same setup and will also try it on another computer.

#4

Updated by Nathalie Blocry almost 11 years ago

  • Status changed from New to Feature implemented

magic_quotes_gpc = off is a good setting ... duh
I have no idea how it got set to "on" but now the problem is solved.

#5

Updated by Stefaan Vanbillemont over 10 years ago

  • Project changed from Chamilo LCMS Connect to Common
#6

Updated by Stefaan Vanbillemont over 10 years ago

  • Target version set to 2.1.0

Also available in: Atom PDF