Project

General

Profile

Bug #2438

Download Course Backup doen't work

Added by Jorge Frisancho over 8 years ago. Updated over 8 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
29/11/2010
Due date:
% Done:

0%

Estimated time:
Spent time:
Complexity:
Piece of cake
SCRUM pts - complexity:
0.5

Description

When you create a backup, you are not allowed to download that file. But the file has been created. I think that the reason is that download.php file in course_info can't catch the admin session.

History

#1

Updated by Jonas Fangstrom over 8 years ago

Jorge Frisancho wrote:

When you create a backup, you are not allowed to download that file. But the file has been created. I think that the reason is that download.php file in course_info can't catch the admin session.

i confirm the bug.

#2

Updated by Ivan Tcholakov over 8 years ago

  • Target version changed from 1.8.6 to 1.8.8 alpha
#3

Updated by Ivan Tcholakov over 8 years ago

I have just tested Chamilo 1.8.8 alpha (current code, not released yet) on Windows Vista, XAMPP 1.7.3.
I used accounts as a platform administrator and as a teacher. I can make course backup file and download it. The feature works for me.

#4

Updated by Julio Montoya over 8 years ago

I test it in http://chamilodev.beeznest.com and also works for me ...

http://chamilodev.beeznest.com/courses/CURSOJMONTOYA2/index.php

i'm using the "Create Complete backup" option

#5

Updated by Fernando Paredes Garcia over 8 years ago

  • Assignee set to Fernando Paredes Garcia
#6

Updated by Fernando Paredes Garcia over 8 years ago

  • Assignee deleted (Fernando Paredes Garcia)
#7

Updated by Fernando Paredes Garcia over 8 years ago

Just installed 1.8.8 in XAMPP Lite 1.7.3 (WinXP), created a course, then went to /main/admin/course_export.php and exported with both options:
"Export all courses" and "Export selected courses from the following list", both allow me to download the backup file.
Perhaps this bug comes from a deployment issue.

#8

Updated by Fernando Paredes Garcia over 8 years ago

  • Status changed from New to Rejected - Abandoned

Could not reproduce the bug.

Also available in: Atom PDF