Project

General

Profile

Bug #2395

take asessment or display complex content?

Added by Koen Favere almost 11 years ago. Updated over 10 years ago.

Status:
Feature implemented
Priority:
Normal
Assignee:
-
Target version:
Start date:
27/11/2010
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal

Description

Courses application : asssessment : display complex content icon (green arrow)
Assessment application : assessment : take asessment icon (same green arrow - diffrerent name)

Fatal error: repository\content_object\assessment\AssessmentMultipleChoiceQuestionDisplay::add_question_form() [<a href='repository\content-object\assessment\assessmentmultiplechoicequestiondisplay.add-question-form'>repository\content-object\assessment\assessmentmultiplechoicequestiondisplay.add-question-form</a>]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "AssessmentMultipleChoiceQuestionOption" of the object you are trying to operate on was loaded before unserialize() gets called or provide a __autoload() function to load the class definition in C:\wamp\www\Chamilo2\repository\content_object\assessment\php\display\component\viewer\wizard\inc\question_display\assessment_multiple_choice_question.class.php on line 46


Files

assessment.cpo (5.29 KB) assessment.cpo Koen Favere, 29/11/2010 13:50

History

#1

Updated by Koen Favere almost 11 years ago

This is a major drawback if this isn't fixed for the 2.0 release. Since it is the heart of the instructional design.

#2

Updated by Koen Favere almost 11 years ago

attached the cpo that raises the problems

#3

Updated by Koen Favere almost 11 years ago

Made a fill in the blanks in an assessment - published in asessment application: works fine!
Will try to move the rest of the questions and give feedback

#4

Updated by Sven Vanpoucke almost 11 years ago

As stated in another post i think this has something to do with imported data but i can not find out why this is happening

#5

Updated by Sven Vanpoucke almost 11 years ago

  • Status changed from New to Needs testing
#6

Updated by Hans De Bisschop almost 11 years ago

Some namespace related changes were made between the release and today .... more then likely results in not being able to import older CPOs

#7

Updated by Koen Favere over 10 years ago

  • Status changed from Needs testing to Needs more info

still not fixed.

#8

Updated by Koen Favere over 10 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Sven Vanpoucke
#9

Updated by Sven Vanpoucke over 10 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Sven Vanpoucke)
  • % Done changed from 0 to 100

The export of content objects from older versions is corrupt for assessments. This data can not be recovered. In a new installation with latest code and newly created assessments this is not an issue anymore.

#10

Updated by Koen Favere over 10 years ago

  • Status changed from Needs testing to Feature implemented
#11

Updated by Stefaan Vanbillemont over 10 years ago

  • Project changed from Chamilo LCMS Connect to Assessment
  • Category deleted (24)
#12

Updated by Stefaan Vanbillemont over 10 years ago

  • Target version changed from 21 to 2.1.0

Also available in: Atom PDF