Project

General

Profile

Bug #2353

other question types also broken

Added by Anonymous about 9 years ago. Updated almost 9 years ago.

Status:
Bug resolved
Priority:
Normal
Target version:
Start date:
25/11/2010
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal

Description

*matching question, error on opening newly created question & similar error on opening existing one
Fatal error: Call to a member function get_full_path() on a non-object in C:\wamp\www\chamilogoogle\repository\content_object\assessment\php\display\component\viewer\wizard\inc\question_display\hotspot_question.class.php on line 35

*rating question:
new: Fatal error: Class 'repository\content_object\assessment_rating_question\RatingQuestionDisplay' not found in C:\wamp\www\chamilogoogle\repository\content_object\assessment_rating_question\php\assessment_rating_question_display.class.php on line 16
existing: Fatal error: Call to undefined method common\libraries\Translation::ge() in C:\wamp\www\chamilogoogle\repository\content_object\assessment_rating_question\php\assessment_rating_question_form.class.php on line 119

types that seem ok:
*multiple choice
*ordering question
*fill in the blanks
*open question
*match question
*matching text question

BTW these last types could easily be merged (in fact the matching text question type only has a few extra options as far as I can see)


Related issues

Related to Assessment - Bug #2351: matrix question brokenFeature implemented25/11/2010

Actions
Has duplicate Repository - Bug #2419: Matrix questionFeature implemented29/11/2010

Actions

History

#1

Updated by Hans De Bisschop about 9 years ago

Just to be certain: I was under the impression that this was working fine up untill yesterday, right?

#2

Updated by Anonymous about 9 years ago

No i'm not certain, could be a bit earlier, i had problems with imported questions after a re-install & Sven thought this (not newly created) was the cause;
I had only time to test open questions then & that was all right.
Beta 2 worked without a problem, so new problems here were a bit of a surprise :-).

#3

Updated by Hans De Bisschop about 9 years ago

  • Assignee set to Hans De Bisschop
  • Target version set to 3

Just did a little test with the rating question and creating one does not lead to errors, editing does (stupid typo seems to be the cause)

#4

Updated by Hans De Bisschop about 9 years ago

Fixed a number of issues involving displays and comparison of assessment question types, including the ones mentionned above ... I hope.

#5

Updated by Hans De Bisschop about 9 years ago

  • Status changed from New to Needs testing
#6

Updated by Anonymous about 9 years ago

*Fill in the blanks: weight field missing on create (edit necessary afterwards to add the weight)

*Matrix: -when deleting possible matches, it appears that these matches are not deleted on create: resulting in a form error
-[solved for new questions]possibility to select the (multiple) matches has disappeared again! just as feedback field: ckeditor change?
-[solved for new questions without deleted options]saving the question saves nothing

*Hotspot: deleted option still shown, also after edit (see also same problem with matrix)

*Ordering question: only standard first three fields are saved, added fields are neglected

*Numerical matching question: error on feedback page after taking assessment:
Fatal error: Class 'repository\content_object\assessment\AssessmentMatchNumericQuestion' not found in C:\wamp\www\chamilogoogle\repository\content_object\assessment\php\display\component\viewer\wizard\inc\score_calculator\assessment_match_numeric_score_calculator.class.php on line 41
(*I'll add more info if necessary after further testing)

#7

Updated by Hans De Bisschop about 9 years ago

Weight is a property of the relationship between a question and an assessment, not a property of the question itself, so when creating a new question the field will never be there. Making this possible (if at all possible) is a separate feature request.

#8

Updated by Sven Vanpoucke about 9 years ago

  • Status changed from Needs testing to New
  • Assignee changed from Hans De Bisschop to Sven Vanpoucke
#9

Updated by Hans De Bisschop about 9 years ago

  • Status changed from New to Bug resolved
  • % Done changed from 0 to 100

Most of this should have been fixed by now. Please retest and open seperate issues for individual problems (aside from the weight feature) if still applicable.

#10

Updated by Stefaan Vanbillemont almost 9 years ago

  • Project changed from Chamilo LCMS Connect to Repository
#11

Updated by Stefaan Vanbillemont almost 9 years ago

  • Target version changed from 3 to 1.0.0

Also available in: Atom PDF