Project

General

Profile

Bug #2351

matrix question broken

Added by Anonymous over 9 years ago. Updated about 9 years ago.

Status:
Feature implemented
Priority:
Normal
Assignee:
-
Target version:
Start date:
25/11/2010
Due date:
% Done:

80%

Estimated time:
Complexity:
Normal

Description

when creating a new matrix question, various elements have gone missing:
-feedback
-multiple select option

when opening an existing question:
Fatal error: repository\content_object\assessment_matrix_question\AssessmentMatrixQuestionForm::setDefaults() [<a href='repository\content-object\assessment-matrix-question\assessmentmatrixquestionform.setdefaults'>repository\content-object\assessment-matrix-question\assessmentmatrixquestionform.setdefaults</a>]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "AssessmentMatrixQuestionOption" of the object you are trying to operate on was loaded before unserialize() gets called or provide a __autoload() function to load the class definition in C:\wamp\www\chamilogoogle\repository\content_object\assessment_matrix_question\php\assessment_matrix_question_form.class.php on line 41


Files

EhB_-_Pegasus_1290701607998.jpeg (142 KB) EhB_-_Pegasus_1290701607998.jpeg Hans De Bisschop, 25/11/2010 17:17

Related issues

Related to Repository - Bug #2353: other question types also brokenBug resolved25/11/2010

Actions

Associated revisions

Revision 06d0d12e (diff)
Added by jmontoyaa over 2 years ago

Save question category when duplicate exercise see #2351

Revision f4c67219 (diff)
Added by jmontoyaa over 2 years ago

Hide question category if setting is on see #2351

Revision 739ed0c6 (diff)
Added by jmontoyaa over 2 years ago

Fix copy exercise when using category order see #2351

History

#1

Updated by Hans De Bisschop over 9 years ago

The options are still there for me :-S
The error might have been fixed by a bunch of fixes applied for issue #2353

#2

Updated by Sven Vanpoucke over 9 years ago

Feedback and options are CKEditors. Could it have something to do with a javascript bug or maybe the platform has changed from url and the javascript still wants to load the web path from the old url.

#3

Updated by Hans De Bisschop over 9 years ago

  • Status changed from New to Needs testing
  • % Done changed from 0 to 100
#4

Updated by Anonymous over 9 years ago

  • % Done changed from 100 to 80

see also update in 2353 about matrix

#5

Updated by Koen Favere over 9 years ago

  • Status changed from Needs testing to Feature implemented
#6

Updated by Stefaan Vanbillemont over 9 years ago

  • Project changed from Chamilo LCMS Connect to Assessment
  • Category deleted (24)
#7

Updated by Stefaan Vanbillemont about 9 years ago

  • Target version changed from 3 to 1.0.0

Also available in: Atom PDF