Project

General

Profile

Bug #2243

learn path cannot create a new object

Added by Juan Carlos Raña Trabado about 9 years ago. Updated almost 9 years ago.

Status:
Bug resolved
Priority:
High
Category:
-
Target version:
Start date:
14/11/2010
Due date:
% Done:

80%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

when I try to create a sequence does not create the objects and returns:

Fatal error: Call to a member function set_level() on a non-object in C:\xampp\htdocs\chamilo\main\newscorm\learnpath.class.php on line 266

History

#1

Updated by Juan Carlos Raña Trabado almost 9 years ago

Creo que el error está en un commit de Julio relacionado con esto:
New LP parameter added: "use_max_score" in the lp table. Admins can change the default value of the max_score to empty. The past default value was 100. See BT#1613.

Perdón si me equivoco.

#2

Updated by Julio Montoya almost 9 years ago

  • Status changed from New to Needs more info
  • Assignee set to Juan Carlos Raña Trabado

Ese campo fue agregado tanto en el main/inc/lib/add_course.lib.inc.php y main/install/migrate-db-1.8.7-1.8.8-pre.sql en su momento.

Para resolver el problema, recuperar la última versión del repositorio y crear un nuevo curso. Si el problema persiste re-abrir la tarea...

#3

Updated by Juan Carlos Raña Trabado almost 9 years ago

El problema no sólo persiste sino que ahora (en una nueva instalación) al intentar crear una lección la herramienta no se carga y aparece una pantalla en blanco

#4

Updated by Juan Carlos Raña Trabado almost 9 years ago

  • Status changed from Needs more info to Assigned
  • Assignee changed from Juan Carlos Raña Trabado to Julio Montoya
#5

Updated by Julio Montoya almost 9 years ago

  • Assignee changed from Julio Montoya to Juan Carlos Raña Trabado
  • % Done changed from 0 to 80

bueno acabo de ver hoy hg version 12965:46847ddf2969 y aparentemente no es error de use_max_score si no la integración de svg , entonces un error tuyo?

( ! ) Parse error: syntax error, unexpected T_IF in /var/www/chamilo-classic/main/newscorm/resourcelinker.inc.php on line 277

ver el commit que arregla esto

http://code.google.com/p/chamilo/source/detail?r=85a4f39c7ea10beb58839779fdbf3285d6991d66&repo=classic

y tambien hay otro error de Ivan aqui

http://code.google.com/p/chamilo/source/detail?r=16d5ea0f16e5386725e082e1ffcf3bb27527e26b&repo=classic&path=/main/inc/lib/add_course.lib.inc.php

Acabo de arreglarlo con esto

http://code.google.com/p/chamilo/source/detail?r=1a383f18b1ded8705a1074c7b51b61b3837dbd45&repo=classic

Para ver los warnings y errores recomiendo activar esta opción en el virtual host y apache.

waiting feedback ....

#6

Updated by Juan Carlos Raña Trabado almost 9 years ago

  • Status changed from Assigned to Bug resolved

Julio, tienes razón, ahora todo parece funcionar correctamente, cuando realicé la nueva instalación la pantalla se veía en blanco porque olvidé incluir un punto y coma (disculpas). También el arreglo del commit de Iván parece haber solucionado la imposibilidad de crear el nuevo objeto por lo que el error parece que no estaba relacionado con tu commit. Así que la tarea puede darse por resuelta. Buen trabajo Julio.

Also available in: Atom PDF