Project

General

Profile

Bug #2240

First entry into a special course generates user error message

Added by Yannick Warnier about 9 years ago. Updated almost 9 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
-
Target version:
Start date:
12/11/2010
Due date:
% Done:

0%

Estimated time:
Complexity:
Easy
SCRUM pts - complexity:
3

Description

When entering a "special" course (auto-register course) for the first time, the user is greeted with a permission error message, which disappears upon the second entry.

This is due to the registration being activated only once the user has entered the course (after the error message). Make sure the special case is taken into account by api_protect_course_script() or whatever function is there.

History

#1

Updated by Alberto Torreblanca almost 9 years ago

  • Assignee set to Alberto Torreblanca
#2

Updated by Alberto Torreblanca almost 9 years ago

Yannick,

Estuve probando un curso 'especial' ... a curso especial te refieres con los cursos en los cuales no hay requisito de inscripciĆ³n .... es decir, cualquiera puede participar ???

#3

Updated by Alberto Torreblanca almost 9 years ago

  • Status changed from New to Rejected - Abandoned

Trate de reproducir el error, pero no lo logre. Al parecer el problema que solucionado la falla ha sido solucionado.

Also available in: Atom PDF