Project

General

Profile

Bug #1831

Export as XLS encoding issue

Added by Olivier CORRE almost 9 years ago. Updated almost 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/08/2010
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

See screenshot.


Files

History

#1

Updated by Ivan Tcholakov almost 9 years ago

I suppose the exported file is UTF-8 encoded, but Excel does not get it. As I remember, while you import from a text/csv file, Excel should ask you about the encoding in some of the wizard's screens?

#2

Updated by Olivier CORRE almost 9 years ago

Tried with both Open office and MS office. The file just opens like that. No pop-up screen asking for encoding.

#3

Updated by Ivan Tcholakov almost 9 years ago

Could you upload here a test file?

#5

Updated by Ivan Tcholakov almost 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Ivan Tcholakov
#6

Updated by Ivan Tcholakov almost 9 years ago

  • Status changed from Assigned to Needs more info
  • % Done changed from 0 to 80

12376:46c0f27a42ad Bug #1831 - Upgrading of the PEAR's package Spreadsheet_Excel_Writer to version 0.9.2. Local changes about Excel export have been made in order defferent input encodings to be supported.
http://code.google.com/p/chamilo/source/detail?r=46c0f27a42ade54049fcf3f7af84a2570fac182a&repo=classic

#7

Updated by Ivan Tcholakov almost 9 years ago

Here is a file with sample results. It contains strings with Cyrillic alphabet, they should be visible.

#9

Updated by Ivan Tcholakov almost 9 years ago

Yes. I am attaching a zip-file with the modified files.

#11

Updated by Ivan Tcholakov almost 9 years ago

  • Status changed from Needs more info to Feature implemented
  • % Done changed from 80 to 100

Thank you very much, I am closing this task.

#12

Updated by Ivan Tcholakov almost 9 years ago

  • Target version set to 1.8.8 alpha
#13

Updated by Olivier CORRE almost 9 years ago

All XLS genreated seem to be copied in /archive. is this normal?

#14

Updated by Ivan Tcholakov almost 9 years ago

Yes. chamilo/archive/ folder in this case (ond others too) serves as a temporary directory. Actually, the files that you download are created there.

#15

Updated by Olivier CORRE over 8 years ago

this bug is also present in the export CSV on the students details page and learnpath detail page.

#16

Updated by Ivan Tcholakov over 8 years ago

  • Status changed from Feature implemented to Needs testing
  • Target version changed from 1.8.8 alpha to 1.8.8 beta
  • % Done changed from 100 to 80

I'll check this...

#17

Updated by Yannick Warnier about 8 years ago

  • Target version changed from 1.8.8 beta to 1.8.8.4
#18

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs testing to New
  • Assignee deleted (Ivan Tcholakov)
  • Target version changed from 1.8.8.4 to 1.9 Stable

Postponing until we get a clear fix.

#19

Updated by Yannick Warnier almost 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya
  • Target version changed from 1.9 Stable to 1.8.8.4

Actually, I'll assign this to Julio for now in case he can quickly fix it with the first changes submitted by Ivan a few months ago which fix other similar things...

#20

Updated by Julio Montoya almost 8 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)

Works for me ... in both pages (student and lp stats) I tried with french accents and some arabic characters .. أبجدية عربية

#21

Updated by Olivier CORRE almost 8 years ago

doesnt work for me when exporting a CSV from /main/tracking/courseLog.php (1.8.8.2)

#22

Updated by Julio Montoya almost 8 years ago

Exporting some weird text and open it with OpenOffice it seems to work for me

#23

Updated by Yannick Warnier almost 8 years ago

  • Assignee set to Olivier CORRE

Olivier, could you please try it from http://chamilodev.beeznest.com (you can enter the platform as admin/admin) and let us know (quickly) if the problem is still there?
We'd like to close 1.8.8 today (4th of August) and we need to know if this bug can be considered closed.

#24

Updated by Olivier CORRE almost 8 years ago

i can't connect to http://chamilodev.beeznest.com. sorry.

#25

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 1.8.8.4 to 1.9 Stable

Oh, OK, didn't think about the Great FireWall, sorry.

Well, I'll jus postpone it to 1.9 then. Please let us know how it goes with 1.8.8.4 when you get a chance.

#26

Updated by Yannick Warnier about 7 years ago

  • Target version changed from 1.9 Stable to 1.9.2
#27

Updated by Julio Montoya almost 7 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee deleted (Olivier CORRE)
  • % Done changed from 80 to 100

I think this is already fixed in chamilo 1.9. This could be tested in http://chamilodev.beeznest.com
Closing for lack of feedback. Feel free to reopen if the bug is still there.

Also available in: Atom PDF