Project

General

Profile

Bug #1670

fckeditor

Added by Ludwig Theunis almost 10 years ago. Updated almost 9 years ago.

Status:
Bug resolved
Priority:
Immediate
Target version:
Start date:
02/07/2010
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

I've installed the Beta on two different places. When I want to publish a document both give an error or a blanc screen when error reporting is off.

In '/common/html/formvalidator/Element/html_editor/fckeditor_html_editor.php.php' on line 7 there is a require for: /plugin/html_editor/fckeditor/fckeditor.php.
To test I changed in locally to: plugin/html_editor/ckeditor/ckeditor.php, this seems to be the solution..

History

#1

Updated by Sven Vanpoucke almost 10 years ago

  • Status changed from New to Needs testing
  • Assignee set to Sven Vanpoucke
  • % Done changed from 0 to 100

I can not seem to reproduce this bug, however it is VERY strange that it still uses FCKeditor instead of CKeditor...

#2

Updated by Stefaan Vanbillemont almost 10 years ago

Retested and no issue here.

#3

Updated by Ludwig Theunis almost 10 years ago

  • % Done changed from 100 to 0

I don't why I get this error on the hosted domain, and not locally on my laptop. But I get the error and I can reproduce it.

Nevertheless it seems to me that the "require_once Path :: get_plugin_path() . 'html_editor/fckeditor/fckeditor.php';" on line 7 in the file: common/html/formvalidator/Element/html_editor/fckeditor_html_editor.php is not correct, because the path does not exists any more.

Probably it has something to do with a php setting, and memory use of the scripting I don't know. I'm wondering to ...

But al settings checked by the installing where green so ???

It happened to me twice on two completely different installations and not on my local installation on my laptop so I think other people will have this problem to.

I checked the common/html/formvalidator/Element/html_editor/fckeditor_html_editor.php from the repository and there the same error in the file still exists.

#4

Updated by Hans De Bisschop almost 10 years ago

FCKEditor is no longer used or should no longer be used. If it is still being used somewhere, then that is the error you're looking for.

#5

Updated by Ludwig Theunis over 9 years ago

I've just installed the Beta2 Hans send us to test the install on different configurations. I've installed the beta2 on my laptop ubuntu 10.04, a collocated server opensuse 9.2 and on hosted webspace (pcextreme, I believe Ubuntu 8.04).
The installation itself was OK.
I just had the same error as with the installation of Beta 1 like I described above in, all of the tested configurations.
On my laptop I installed the beta on a new database and it gave the same error as the collocated server and the hosted webspace.
The latest Chamilo installation from mercurial on my laptop was running OK. I've checked why, and I found out that it gave no error because the fckeditor files still exists in the mercurial: plugin/html_editor/fckeditor ...

When publishing a document in the courses:document or in de repository the screen was blanc or a fatal-error message is shown.
The message is:
'*Fatal error: require_once() [function.require]: Failed opening required '/home/thlu/workspace/chamilo_beta_2/common/html/formvalidator/Element/html_editor/fckeditor_html_editor.php' (include_path='/home/thlu/workspace/chamilo_beta_2/plugin/pear:/home/thlu/workspace/chamilo_beta_2/plugin/google/library') in /home/thlu/workspace/chamilo_beta_2/common/html/formvalidator/Element/upload_or_create.php on line 10*'

Because Hans stated that fckeditor should not be used anymore, I searched a little bit further and found that in the file /common/html/formvalidator/Element/upload_or_create.php on line 10 /require_once dirname(FILE) . '/html_editor/fckeditor_html_editor.php'; is not correct and should be erased.
I deleted these lines in all installations, and this fixed the error.
Probably the directory /common/html/formvalidator/element/html_editor can be deleted to, or they have to be updated.

Searching for this bug I found another bug I will post in a new Issue....

#6

Updated by Hans De Bisschop over 9 years ago

  • Priority changed from Normal to Immediate

Thanks for the analysis Ludwig. We'll fix this first thing in the morning.

#7

Updated by Stefaan Vanbillemont about 9 years ago

  • Status changed from Needs testing to Bug resolved
#8

Updated by Stefaan Vanbillemont about 9 years ago

  • Project changed from Chamilo LCMS Connect to Common
  • Category deleted (21)
#9

Updated by Stefaan Vanbillemont almost 9 years ago

  • Target version changed from 18 to 1.0.0

Also available in: Atom PDF