Project

General

Profile

Bug #1420

Assessment options

Added by Anonymous over 10 years ago. Updated over 9 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Hans De Bisschop
Target version:
Start date:
02/06/2010
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

When adding options to a question, the values that are entered in htmleditors are not saved.
This happens when one removes an option in between and not at the end.
So first an option is added at the end and then one is removed before that option.
The cause of them not being saved is because the values are not posted. (so are missing in the $_POST variable)
This only seems to happen with the CKEditor.

History

#1

Updated by Anonymous over 10 years ago

  • Category set to 24
  • Target version set to 2
#2

Updated by Hans De Bisschop over 10 years ago

  • Assignee set to Hans De Bisschop

This problem should have been fixed already. I'll check it out and fix if and where necessary.

#3

Updated by Hans De Bisschop over 10 years ago

Should be fixed now for all question types. For future reference: CKEditor instances need to be destroyed first before the element can be removed (unlike TinyMCE editor instances). If you don't do this, it will cause Javascript errors upon posting the form, causing everything after the deleted editor to be lost.

To destroy an HTML Editor in javascript, use the following:

destroyHtmlEditor(editorName);

#4

Updated by Hans De Bisschop over 10 years ago

  • Status changed from New to Needs testing
#5

Updated by Stefaan Vanbillemont over 10 years ago

  • Status changed from Needs testing to Bug resolved

Tested and fixed!

#6

Updated by Stefaan Vanbillemont over 9 years ago

  • Project changed from Chamilo LCMS Connect to Assessment
  • Category deleted (24)
#7

Updated by Stefaan Vanbillemont over 9 years ago

  • Target version changed from 2 to 1.0.0

Also available in: Atom PDF