Project

General

Profile

Bug #1251

Learning Path > build > positioning menu error

Added by Hubert Borderiou over 9 years ago. Updated over 9 years ago.

Status:
Bug resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
06/05/2010
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi,

I've found a new way to have wong arrows on the Organize tool for Learning Paths.
I think it is the main reason why teachers have problem with Learning Path-organization -arrows.
(eventually more than frantic clicking I hope)

Sometime, the Positioning menu, when you add a LP Object or a section, is wrong, and, nethertheless, if you add the ressource, you have an arrow error. I guess, error too on the database on Previous_item, Next_item fields.

See attached screencast (2') to see how to reproduce this issue.


Files

beeznest_187_LP_pb_wirth_menu.swf (2.15 MB) beeznest_187_LP_pb_wirth_menu.swf Screencast for LP menu issue Hubert Borderiou, 06/05/2010 15:17

History

#1

Updated by Hubert Borderiou over 9 years ago

Fix :
to prevent this issue, edit file
/main/newscorm|learnpath.class.php
and replace every

if ($arrLP[$i]['parent_item_id'] == $parent

with
if ($arrLP[$i]['parent_item_id'] == $parent_item_id

and it works fine.

There are 8 of them, in functions
display_quiz_form
display_hotpotatoes_form
display_forum_form
display_thread_form
display_item_form
display_document_form
display_link_form
display_student_publication_form

#2

Updated by Hubert Borderiou over 9 years ago

Need more testing...

#3

Updated by Julio Montoya over 9 years ago

  • Target version changed from 1.8.7 RC1 to 1.8.7
#4

Updated by Yannick Warnier over 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya
  • Priority changed from Normal to Urgent
#5

Updated by Anonymous over 9 years ago

  • Status changed from Assigned to Needs more info
  • % Done changed from 0 to 100

Done (see http://code.google.com/p/chamilo/source/detail?r=873035c45268abb7eba7e0341393c369b8a3ab9a&repo=classic). Waiting for feedback and more testing. I also added Hubert to the list of contributors in documentation/credits.html

#6

Updated by Hubert Borderiou over 9 years ago

Still some problem with it...
It corrects this issue but seems to add some :s
I'm still working on it
I will keep you informed

#7

Updated by Julio Montoya over 9 years ago

Thanks for the clear screencast... I will check this one. Hope to find something.

#8

Updated by Julio Montoya over 9 years ago

I found an error when selecting a document the parent id is set to 0.

http://code.google.com/p/chamilo/source/detail?r=c970a43aefe01ba09263309e991f5f20fb77294c&repo=classic

For me seems to work...

#9

Updated by Hubert Borderiou over 9 years ago

Seems to be fine for me too with both modification... nice ^^

#10

Updated by Julio Montoya over 9 years ago

  • Status changed from Needs more info to Bug resolved

good job

Also available in: Atom PDF