Project

General

Profile

Bug #1161

hotspot question

Added by dominique de guchtenaere over 9 years ago. Updated over 9 years ago.

Status:
Bug resolved
Priority:
High
Category:
-
Target version:
Start date:
30/04/2010
Due date:
% Done:

80%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
2

Description

still refering to Dokeos when creating a hotspot question


Files

hotspot.zip (897 KB) hotspot.zip Anonymous, 14/05/2010 22:44
hotspot-modificado.rar (565 KB) hotspot-modificado.rar hotspot Luis Rodriguez, 14/05/2010 23:09
Screenshot.png (11.7 KB) Screenshot.png lol Julio Montoya, 17/05/2010 17:58
Selection_001.png (15.3 KB) Selection_001.png Julio Montoya, 17/05/2010 18:04

Related issues

Related to Chamilo LMS - Bug #1752: Broken text (french) in image zone questionBug resolved22/07/2010

Actions
Related to Chamilo LMS - Feature #189: Replacing Dokeos(TM) elements with ChamiloNeeds more info27/11/200916/03/2010

Actions

History

#1

Updated by Yannick Warnier over 9 years ago

  • Assignee set to Julio Montoya
  • Priority changed from Normal to High
  • SCRUM pts - complexity changed from ? to 2

Implies rebuilding the hotspot Flash application

#2

Updated by Julio Montoya over 9 years ago

  • Status changed from New to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier

I created a hotspot (Image zone) and I do not see a text refering Dokeos.

#3

Updated by Yannick Warnier over 9 years ago

When loading the hotspot tool, the Dokeos logo appears (loading...). Probably easier to see if you upload a large image or see the hotspot tool on a remote server.

#4

Updated by Yannick Warnier over 9 years ago

  • Status changed from Needs more info to Assigned
  • Assignee changed from Yannick Warnier to Julio Montoya
#5

Updated by Julio Montoya over 9 years ago

  • Target version changed from 1.8.7 RC1 to 1.8.7
#6

Updated by Yannick Warnier over 9 years ago

  • Assignee changed from Julio Montoya to Anonymous

Need to check the sources of hotspot flash plugin from inside the main/plugin/hotspot directory, pass them to Luis and ask him to put Chamilo instead of Dokeos in the source and recompile (and upload the new sources and compiled version in repository)

#7

Updated by Anonymous over 9 years ago

Here are the files, Luis... If you can recompile them and provide me a new zip with the recompiled files, I'll upload them to the repository.

#9

Updated by Anonymous over 9 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Luis Rodriguez to Anonymous
  • % Done changed from 0 to 100
#10

Updated by Anonymous over 9 years ago

  • Assignee changed from Anonymous to Julio Montoya

Reassigning to you, julio, so you can give me some feedback and close the task if everything is ok

#11

Updated by Julio Montoya over 9 years ago

Chameleon? That's our new name? :)

#12

Updated by Anonymous over 9 years ago

  • Status changed from Needs more info to Assigned
  • Assignee changed from Anonymous to Luis Rodriguez

Apparently, that's the picture Luis added as a logo... Reassigning the task to him...

#13

Updated by Julio Montoya over 9 years ago

Also there is something wrong in the swf, because I create a new hot spot (Quiz tool) and It keeps loading with a big image or with a tiny image. I can't see the image loaded.

Then when viewing as a student I get this image (see attachment).

#14

Updated by Julio Montoya over 9 years ago

Hot spot is not working right now. Please replace with the last working swf and fla.

#15

Updated by Julio Montoya over 9 years ago

  • Assignee changed from Luis Rodriguez to Anonymous
#16

Updated by Anonymous over 9 years ago

  • Assignee changed from Anonymous to Luis Rodriguez

Ok I reverted the hotspot tool back to the older version.

Luis > I'm reassigning the task to you so you can:
  • first update the logo so that it doesn't have "Chameleon" on it
  • second see if you can fix the bugs that Julio is talking about, and provide a new swf that works
#18

Updated by Julio Montoya over 9 years ago

The "hotspot question option" did not work when the fix (Change D*** logo to Chamilo) was implemented.

Yannick Warnier wrote:

What is the revert for? (http://code.google.com/p/chamilo/source/detail?repo=classic&r=ff4e7bb8eca997b081763ec2c54290f770787ac1)

#19

Updated by Yannick Warnier over 9 years ago

  • Target version changed from 1.8.7 to 1.8.7.1

Let's move this to 1.8.7.1, we have no time to play around with visual details of this magnitude here...

#20

Updated by Ivan Tcholakov over 9 years ago

I have a request for help about the task #1752. Is it possible the files hotspot_admin.fla, hotspot_solution.fla and hotspot_user.fla to be recompiled with the following change - all the lines

System.useCodepage=true;

to be commented (disabled). Thus, UTF-8 will be the default encoding within the swf object, hotspot tests will become usable.

I can't compile these fla files.

#21

Updated by Yannick Warnier over 9 years ago

Ivan Tcholakov wrote:

I have a request for help about the task #1752. Is it possible the files hotspot_admin.fla, hotspot_solution.fla and hotspot_user.fla to be recompiled with the following change - all the lines

System.useCodepage=true;

to be commented (disabled). Thus, UTF-8 will be the default encoding within the swf object, hotspot tests will become usable.

I can't compile these fla files.

Luis is the right person to compile the flas. I'll ask him in around 8 hours. Should be possible to get it into 1.8.7.1

#22

Updated by Yannick Warnier over 9 years ago

A few updates on this. The logo breaks apparently because the SWF compiles with an error, that is that it cannot load the JavaScriptProxy class or something like that. So we're having the problem too, basically, when trying to fix the encoding problem.

Also available in: Atom PDF